TruEdit System Requirements

Questions about the information below can be sent to trueditsupport@maned.com.

TruEdit Web Client, TruAuthor and Admin
  • Chrome 56.0 or newer
  • Firefox 51 or newer
  • Internet Explorer 10 or newer
  • Safari 10.0 or newer
TruEdit Overview & Dashboards
  • macOS 10.10 or newer
  • Windows 7, Windows 8.1, or Windows 10
  • Adobe AIR v32.0 or newer
TruEdit Toolbox Import/Export Utility (TEUtils)
  • Java SE Development Kit 8
TruEdit Plug-ins for 
Adobe InDesign CC 2021 &
Adobe InCopy CC 2021*
TruEdit Plug-ins for 
Adobe InDesign CC 2020 &
Adobe InCopy CC 2020*
TruEdit Plug-ins for 
Adobe InDesign CC 2019 &
Adobe InCopy CC 2019*
TruEdit Plug-ins for
Adobe InDesign CC 2018 &
Adobe InCopy CC 2018*
MacOS
  • Multicore Intel processor
  • MacOS version 10.14 - 11 (Mojave through Big Sur)
  • 4 GB of RAM (16 GB recommended)
  • Adobe InDesign CC 2021
  • Adobe InCopy CC 2021
MacOS
  • Multicore Intel processor
  • MacOS version 10.13 - 10.15
  • 4 GB of RAM (16 GB recommended)
  • Adobe InDesign CC 2020
  • Adobe InCopy CC 2020
MacOS
  • macOS 10.12 - macOS 10.14
  • Adobe InDesign CC 2019
  • Adobe InCopy CC 2019
MacOS
  • macOS 10.11 - macOS 10.13
  • Adobe InDesign CC 2018.1 or newer
  • Adobe InCopy CC 2018.1 or newer
 
Windows
  • Microsoft Windows Windows 10 (versions 1607, 1809, 1903, 1909, 2004)
  • 4 GB of RAM (16 GB recommended)
  • Adobe InDesign CC 2021
  • Adobe InCopy CC 2021

 

     
     
    Windows
    • Microsoft Windows 7 (64-bit) with Service Pack 1 or Windows 10* (64-bit)
    • 4 GB of RAM (16 GB recommended)
    • Adobe InDesign CC 2020
    • Adobe InCopy CC 2020
     
    Windows
    • Windows 7 with SP1 or Windows 10 (except not supported on Windows 10 versions 1507, 1511, and 1607)
    • Adobe InDesign CC 2019
    • Adobe InCopy CC 2019
     
    Windows
    • Windows 7 with SP1, Windows 8, Windows 8.1, or Windows 10
    • Adobe InDesign CC 2018.1 or newer
    • Adobe InCopy CC 2018.1 or newer

    * TruEdit requirements are in addition to those specified by Adobe.
    For More details see InDesign system requirements and InCopy system requirements pages.